Issues with Booking with the Legend Integration

Incident Report for myFitApp

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 10:31 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2026 - 10:08 GMT

Update

Further reports suggest this is not affect all Legend customers however a fix has been identified by Legend and is being worked on. This is planned to be released by 10:00UTC.
Posted Feb 04, 2026 - 08:53 GMT

Identified

We have identified an issue with the Legend strikes feature. This has been raised with Legend. Until this issue is resolved the Legend strikes feature will be disabled for all accounts. This will be happening in the next 5 mins.
Posted Feb 04, 2026 - 07:36 GMT

Investigating

We are currently investigating and working with Legend.
Posted Feb 04, 2026 - 07:27 GMT
This incident affected: Third Party Integrated Services.