Intermittent issues with Legend

Incident Report for myFitApp

Resolved

Legend has resolved the issue.
Posted Nov 20, 2025 - 09:46 GMT

Investigating

There are currently issues reported with the Legend platform. This is unrelated to myFitApp. We’re working to assist Legend where we can.
Posted Nov 20, 2025 - 08:18 GMT
This incident affected: Third Party Integrated Services.